Customers are unable to log into Yotpo SMS & Email through Shopify

Incident Report for Yotpo

Resolved

This incident has been resolved.
Posted May 19, 2025 - 18:27 IDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 19, 2025 - 18:08 IDT

Investigating

We are investigating an interruption in the Yotpo SMS & Email app, causing customers not being able to log into Yotpo SMS & Email through Shopify.

At the moment we recommend logging in through https://email-and-sms.yotpo.com/

We apologize for the temporary inconvenience. More details to follow in the next status update

The Yotpo Support Team
Posted May 19, 2025 - 16:51 IDT
This incident affected: SMS & Email Marketing (Admin).