Yotpo Loyalty Admin inaccessible

Incident Report for Yotpo

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 12:12 IST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2025 - 11:24 IST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 17, 2025 - 11:13 IST

Investigating

We are investigating an interruption in the B2B service, causing the Loyalty admin to be temporarily inaccessible. Additionally, some on-site widgets fail to load, and merchants might experience issues with some API calls.

Our R&D team has identified the issue and is currently working on a resolution.

We apologize for the temporary inconvenience. More details to follow in the next status update

The Yotpo Support Team
Posted Nov 17, 2025 - 11:13 IST
This incident affected: Platform (Yotpo Admin, API integration with Yotpo), Loyalty & Referrals (Admin, API, Widgets (Pop-up, Rewards Page)), and Admin, API, Widgets (Product Page Widget, Customer Portal).