Yotpo Service Disruption notice

Incident Report for Yotpo

Resolved

The incident has been fully resolved, and redemptions are now working as expected
Posted Mar 18, 2026 - 12:42 UTC

Monitoring

The incident has been fully resolved, and redemptions are now working as expected
Posted Mar 18, 2026 - 12:39 UTC

Investigating

We’re investigating an issue affecting the Point Redemption service, which is preventing customers from redeeming points.

At the moment, we are working on resolving the issue as soon as possible.

We apologize for the temporary inconvenience. More details to follow in the next status update

The Yotpo Support Team
Posted Mar 18, 2026 - 12:02 UTC
This incident affected: Loyalty & Referrals (API, Widgets (Pop-up, Rewards Page)).