Overall Description of the Issue and Affected Services: Users experience login issues and is redirected to an error page.
Start Time: Apr 08, 2026 - 22:04 (UTC).
End Time: Apr 08, 2026 - 23:40 (UTC).
Business Impact: We are currently investigating an issue affecting users that are unable to login into their Yotpo account.
At the moment, we are working on resolving the issue as soon as possible.
We apologize for the temporary inconvenience. More details to follow in the next status update. If you have any further questions or concerns, please feel free to reach out to us by live chat or by submitting a support case.
The Yotpo Support Team.
Posted Apr 08, 2026 - 23:57 UTC
Monitoring
The fix has been successfully implemented, and we are actively monitoring the results.
Posted Apr 08, 2026 - 23:38 UTC
Identified
The root cause has been identified, and our team is currently working on implementing a fix.
Posted Apr 08, 2026 - 23:30 UTC
Investigating
We are currently investigating an issue affecting users that are unable to login into their Yotpo account.
At the moment, we are working on resolving the issue as soon as possible.
We apologize for the temporary inconvenience. More details to follow in the next status update.