Shopify Platform Account Status does not get Updated in Loyalty
Incident Report for Yotpo
Resolved
This incident has been resolved and there has been no data loss. All customer platform account statuses have been updated.
Posted Aug 03, 2024 - 00:00 IDT
Update
We are continuing to investigate this issue.
Posted Aug 02, 2024 - 23:29 IDT
Update
Overall Description of the issue and Affected Services:

We are currently experiencing an issue affecting our Shopify integration. Customers who create an account on your Shopify store will not have their account marked as having an account on your platform in Yotpo.

Start Time:
7:18pm UTC

Business Impact:
- Platform account status will not be updated in Yotpo for newly created accounts in Shopify.
- This will cause customers to not receive a "Create an Account" reward for creating a platform account.
- If your opt-in strategy is set to "Platform Accounts Only", these customers will not be opted in automatically following account creation.

Workarounds:
- Our Customer Update API call (https://loyaltyapi.yotpo.com/reference/createupdate-customer-records) can be used to mark customers as having a platform account by setting the has_account value to "true". By default, the "platform_account_created_at" value takes the current time.

We apologize for the inconvenience caused. Our R&D team is already working on fixing this issue.

If you have any further questions or concerns, please feel free to reach out to us by live chat or by submitting a support case.

The Yotpo Support Team
Posted Aug 02, 2024 - 23:27 IDT
Investigating
We are currently investigating this issue.
Posted Aug 02, 2024 - 23:15 IDT
This incident affected: Loyalty & Referrals (Admin).