Issue when accessing the Yotpo Apps

Incident Report for Yotpo

Resolved

This incident has now been resolved, all functionalities are back to normal and you should be able to access the Yotpo Apps without issues, we appreciate your kind patience and understanding while we resolved this matter.
Posted May 28, 2025 - 00:30 IDT

Monitoring

Our team has applied a fix and logging-in to Yotpo apps are now accessible, we are monitoring the fix. We appreciate your kind patience and understanding.
Posted May 28, 2025 - 00:22 IDT

Investigating

You may encounter an issue logging-in to the Yotpo apps, our team is looking into this.
Posted May 27, 2025 - 23:32 IDT
This incident affected: Platform (Yotpo Admin), Reviews and UGC (Admin), SMS & Email Marketing (Admin), and Subscriptions (Admin).