The issue affecting the Loyalty Home Page has now been resolved, and the page is loading normally.
Thank you for your patience and understanding while our R&D team worked to resolve the issue.
If you continue to experience any problems, please reach out to us via live chat.
The Yotpo Support Team
Posted Sep 24, 2026 - 09:10 UTC
Investigating
Start Time: 9:45 AM UTC
The Loyalty Home Page is currently experiencing issues that may prevent it from loading correctly. You may see an error message such as, “Looks like something’s gone wrong.”
Our R&D team is currently investigating the issue. We’ll post further updates here as soon as we have more information.
We apologize for any inconvenience this may cause.
If you have any questions or concerns, please feel free to reach out to us via live chat.
The Yotpo Support Team
Posted Sep 24, 2026 - 09:06 UTC
This incident affected: Loyalty & Referrals (Admin).