Yotpo Service Disruption notice.

Incident Report for Yotpo

Resolved

This incident has been resolved.
Posted May 12, 2025 - 17:01 IDT

Investigating

We are investigating an interruption in the Flows/Flows editor service, causing issue, where flows are not opening, otherwise working as expected.

We apologise for the temporary inconvenience. More details to follow in the next status update.

The Yotpo Support Team
Posted May 12, 2025 - 16:57 IDT