Yotpo Service Disruption notice - "Integrations" page not loading.

Incident Report for Yotpo

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 12:37 IDT

Investigating

We are investigating an interruption in the integrations service, causing the "Integrations" page to not load. Integrations itself are intact.

We apologize for the temporary inconvenience. More details to follow in the next status update.

The Yotpo Support Team
Posted Apr 09, 2025 - 12:31 IDT
This incident affected: SMS & Email Marketing (Integrations).