Email Campaigns Template Editor – Loading Issue

Incident Report for Yotpo

Resolved

This incident has been resolved, and the Email Campaigns template editor is now working as expected.

Thank you for your patience while this was being addressed.
Posted Aug 28, 2025 - 16:32 IDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 28, 2025 - 15:32 IDT

Investigating

We are investigating an issue where some users might experience a white page when trying to load the Email Campaigns template editor.

The editor continues to load as expected from Flows and Email Templates.

Our R&D team is actively working on identifying the cause, and updates will be shared here as they become available.
Posted Aug 28, 2025 - 15:21 IDT
This incident affected: SMS & Email Marketing (Admin).