Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 02, 2026 - 08:00 UTC
Scheduled
We are currently performing maintenance on the UGC Conversion Dashboard to improve the accuracy of conversion analytics.
Some conversion metrics in the dashboard may be incomplete or inaccurate for reporting periods beginning in January 2026. This impacts reporting only and does not affect the functionality of on-site review widgets or the shopper experience.
Our engineering team is actively working to restore accurate reporting. As part of this effort, we are evaluating enhancements to our data processing approach to ensure the long-term accuracy and reliability of conversion metrics. We expect this evaluation to continue over the next two weeks.
During this time, some conversion metrics may continue to appear incomplete or inconsistent. We will provide another update as soon as we have additional information to share.
We appreciate your patience as we work toward a long-term resolution.
Posted Jul 02, 2026 - 07:51 UTC
This scheduled maintenance affects: Reviews and UGC (Admin).