Yotpo Service Disruption notice

Incident Report for Yotpo

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 10:51 IDT

Investigating

We are investigating an interruption in the login service, causing login issues.

We apologize for the temporary inconvenience. More details to follow in the next status update.

The Yotpo Support Team
Posted Jul 14, 2025 - 10:43 IDT
This incident affected: SMS & Email Marketing (Admin).