Moderation Page Unavailable

Incident Report for Yotpo

Resolved

The issue affecting the Moderation page has been resolved. All moderation functionality is operating normally. We apologize for the inconvenience.
Posted Jul 07, 2026 - 14:17 UTC

Investigating

We are aware of an issue preventing the Moderation page from loading in the Yotpo platform.
Our team is actively investigating.
Review collection and publishing are not affected.
Posted Jul 07, 2026 - 14:02 UTC
This incident affected: Reviews and UGC (Admin).