Customers tab on the Loyalty admin does not show any data

Incident Report for Yotpo

Resolved

End Time 20:25 CET
The issue has been resolved.

Thank you for your patience!
Posted Apr 14, 2026 - 19:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 14, 2026 - 16:56 UTC

Investigating

Start time 16:00 CET.
Our R&D team is currently investigating the issue.
Not everyone is affected.
Posted Apr 14, 2026 - 15:11 UTC
This incident affected: Loyalty & Referrals (API).