Yotpo Service Disruption Notice - Yotpo Admin might not be accessible

Incident Report for Yotpo

Resolved

We deployed a fix and monitored the login service until performance returned to normal. The issue is resolved, and we apologize for any inconvenience this caused.

The Yotpo Support Team
Posted Aug 27, 2025 - 00:40 IDT

Update

We are continuing to investigate this issue.
Posted Aug 26, 2025 - 20:56 IDT

Investigating

We are currently investigating an issue causing heavy latency in the login service, which may prevent some users from signing in. We will share more information as soon as it’s available and apologize for the disruption.

The Yotpo Support Team
Posted Aug 26, 2025 - 20:55 IDT
This incident affected: Platform (Yotpo Admin) and Reviews and UGC (Admin).