Chat Support

Incident Report for Yotpo

Resolved

This incident has been resolved.

Thank you for your patience.
Posted Jun 09, 2025 - 15:00 IDT

Investigating

We're currently experiencing an issue with our chat support system, and chats are temporarily unavailable.

Our team is actively working to resolve the problem as quickly as possible.

In the meantime, you can still reach us by submitting a support ticket using the "Contact Us" option in the top bar.

Thank you for your patience and understanding!
Posted Jun 09, 2025 - 09:54 IDT
This incident affected: Platform (Yotpo Admin).