Access to the Review requests dashboard might currently not be available.

Incident Report for Yotpo

Resolved

The issue has been resolved and the functionality is back to normal.

We thank you for your patience on this matter.
Posted Feb 11, 2026 - 11:45 UTC

Monitoring

A fix is implemented and we're currently monitoring the behaviour.
Posted Feb 11, 2026 - 11:42 UTC

Identified

Our engineering team have identified the underlying issue and are currently working on a fix.
Posted Feb 11, 2026 - 11:05 UTC

Investigating

Using the Review Requests Dashboard might currently not be available.

Start time:

11 Feb, 2026 - 11:00 AM [UTC].

We apologise for the inconvenience and appreciate your patience while our engineering teams are working to resolve the matter.

The Yotpo Support Team.
Posted Feb 11, 2026 - 11:03 UTC
This incident affected: Reviews and UGC (Admin).