Yotpo Service Degradation | May 8, 2026

Incident Report for Yotpo

Resolved

The incident has been fully resolved.
Posted May 08, 2026 - 09:49 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 08, 2026 - 05:34 UTC

Identified

Overall Description of the issue and Affected Services:
1. Data ingestion from Ecommerce platforms
2. Webhook Delivery System

Start Time:
May 8, 2026 - 01:55 (UTC).

Business Impact:
Data ingestion, such as order/product creation or updates, as well as webhook delivery, will have delays due to an ongoing AWS incident. No data loss is expected.

We apologize for the inconvenience and appreciate your patience while our engineering teams is working to resolve the issue.

If you have any further questions or concerns, please feel free to reach out to our Technical Support by submitting a Support case.

The Yotpo Support Team.
Posted May 08, 2026 - 03:20 UTC
This incident affected: Platform (API integration with Yotpo).