Minor Degradation in Order Processing and Redemptions

Incident Report for Yotpo

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 05:24 IDT

Monitoring

We are currently monitoring an elevated rate of errors affecting order and redemption processing closely and will continue to asses and provide updates as needed. Thank you for your patience.
Posted Aug 26, 2025 - 19:42 IDT
This incident affected: Loyalty & Referrals (Database).